Google will phase out Manifest V2 extensions for Chrome, mandatory V3 starting in 2023 – Computer – News

From June 2023, Google Chrome will no longer support extensions based on Manifest V2 requirements. As of January 17, 2022, new extensions based on Manifest V2 will no longer be included in the Chrome Web Store.

Until early 2023, developers had time to make existing extensions compatible with Manifest V3, late Know Google’s blog post. From that moment on, existing V2 extensions can no longer be updated to meet the new requirements. When version 3 of the extension requirement finally becomes mandatory, all currently outdated extensions based on Manifest V2 will no longer work.

The current format for Chrome extensions was released early this year and places a strong focus on privacy, performance improvement, and security. For V3 extensions, among other things, it is no longer possible remote code This makes it easier for Google to test the security of an extension. In addition, the new format makes it possible for service workers To perform certain tasks in the background. This eliminates the need for an additional web page for secondary functions, which reduces Chrome’s RAM consumption.

Finally, a controversial new declarativeNetRequestIntroduce -api as a replacement for the current one webRequest-My Father. As a result, it became Ad blockers made it more difficultIn the interest of user privacy. The concerned person API will be modified in the meantime It is to protect the wishes of the developers and the privacy of the user.

Leave a Reply

Your email address will not be published. Required fields are marked *